[Pybots] Anyone interested in working with python3.0 branch?

Grig Gheorghiu grig at gheorghiu.net
Tue Mar 18 13:15:22 PDT 2008


--- Graeme Glass <graemeglass at gmail.com> wrote:

> 
> I have an Ubuntu machine you can use. What would be the most pressing
> branch that needs a slave? (3.0, 2.6) Or perhaps a third party
> package?
> Just let me know and I can set it up and get it going.
> 

Hi, Graeme

Thanks for responding to my message. Generally speaking, it's up to the
buildslave owner to select a package that they want tested on their
slave, and also to specify whether they are interested in a given
branch (or all). 

Is there a specific Python package that you'd be interested in testing?
I personally think the 3.0 branch is the most interesting at this
point, but I also recognize that most of the packages out there will
break when built against 3.0, unless you run 2to3 on them and try to
make them py3k-compatible. I think people will need to start doing this
at some point, and we here at Pybots can be on the cutting edge of this
process.

Grig



More information about the Pybots mailing list